• 1
  • 2
  • 2
  • 13
  • 14
  • 15
  • 16
вернуться на главную

Компьютеризированная обработка, представление и хранение данных гидробио-логического анализа

Обработка результатов количественного анализа фитопланктона с определением до видового и родового уровней и последующим вычислением индекса сопробности пробы является весьма трудоемкой и кропотливой задачей.

Однако использование компьютера, оснащенного электронными таблицами, в частности EXCEL 7,0 (WINDOWS 95), позволяет любому пользователю, даже не знающему ни одного языка программирования, существенно облегчить обработку результатов гидробиологических анализов.

Рассмотрим применение EXCEL на примере программы, используемой в отделе биологических методов анализа ЗАО «РОСА» для обработки результатов количественного анализа фитопланктона и вычисления индекса сапробности.

Программа" обсчета данных состоит из одного файла «phyto.xls», включающего в себя два листа: «Названия» и «Результаты».

Лист «Названия» представляет собой список встречающихся видов фитопланктона с нужной нам дополнительной информацией о них. Этот список создается в процессе систематической практической работы. Вновь встреченные виды вносятся в этот список, им присваивается порядковый номер. Для удобства пользования списком при накоплении большого количества видов список можно отсортиро­вать в алфавитном порядке, присвоив затем видам новые номера по возрастанию. Можно с уверенностью сказать, что при систематическом исследовании одного водоема или группы водоемов, связанных общностью географического положения, лист «Названия» будет заполнен в течение 1-2 лет и дополнения в него будут вноситься редко.

На иллюстрации приведен начальный фрагмент списка видов, встреченных в пробах воды из р.Москвы (из него исключены виды, для которых не определен индекс сапробности). Этот список состоит из следующих разделов: порядковый номер вида (столбец А); латинское название (столбец В); таксономическая группа (столбец С); индивидуальный вес клеток (столбец D), определенный на основании собствен­ных измерений и расчетных формул; индекс сапробности (столбец Е) и зона сапробности (столбец F). Второй частью «программы» является лист «Результаты». Верхняя часть (строки 3-8) содержит иден­тификационную информацию о пробе, а также данные, необходимые для расчета численности по пер­вичным результатам. Основная часть листа, содержащая информацию о видовом составе и численно­сти, имеет заданные связи с листом «Названия». Непосредственно вручную в таблицу вносятся порядко­вые номера (столбец А) и численности клеток в исследованной части пробы (столбец D). Остальная часть таблицы заполняется автоматически благодаря связям с листом «Названия» и связям в пределах листа. Рассмотрим эти связи.

Столбец А, как уже отмечалось, заполняется вручную. Для ячеек столбца В задана следующая функция: = ИНДЕКС(Названия!$В:$В;ПОИСКПОЗ(А(номер строки);Названия!$А:$А;0)).

Записана эта функция с использованием стандартных функций EXCEL, описание которых содержит­ся в программе (меню — "вставка«- «функция»). Благодаря этой функции латинские названия, соответствующие своему порядковому номеру, автоматически забираются из листа Названия«.

Следует особо подчеркнуть, что для удобства работы первичную информацию о подсчете фито­планктона в пробе нужно заносить в карточки, представляющие собой часть листа «Названия». Для создания этих карточек следует вставить в листе «Названия» столбец после столбца С (он будет использоваться для записи результатов счета), выделить область печати (столбцы A-D) и сделать нужное коли­чество копий (количество исследуемых проб равно количеству копий). В такой рабочей карточке поряд­ковый номер вида будет располагаться рядом с его названием, что даст возможность при математичес­кой обработке пробы быстро вводить вручную только номер вида.

Для ячеек столбца С задана следующая функция: =ИНДЕКС(Названия!$С:$С;ПОИСКПОЗ(А(номер строки);Названия!$А:$А;0)), переносящая из листа «Названия» в лист «Результаты» соответствующую виду таксономическую группу (д — диатомовые, с-з -сине-зеленые и т.д.).

Столбец D заполняется вручную по карточке первичного обсчета пробы.

Для ячеек столбца Е задана функция: = D(номер строки)*(((1/$D$7)/$D$8)/(($D$5/$D$6)*1000)). Выражение в скобках справа от знака умно­жения в формуле представляет собой коэффициент пересчета первичных данных учета численности в численность, выраженную в тысячах клеток на миллилитр. В этом выражении даются абсолютные ссылки на ячейки листа «Результаты», содержащие необходимую для пересчета информацию (D7 — объем од­ной полосы камеры Нажотта 0,05мл, D8 — количество исследованных полос, D5 — объем отобранной пробы, D6 — объем до которого проба была сконцентрирована).

Значения ячеек столбца F описываются функцией: =ИНДЕКС(Названия!$D:$D;ПОИСКПОЗ(А(номерстроки);Названия!$А:$А;0)), которая переносит из листа «Названия» соответствующие порядковым номерам индивидуальные веса клеток.

Значения ячеек столбца G определяются формулой: =E(номер строки)*F(номер строки), представляя биомассу вида в мг/л. В ячейке G50 значения ячеек столбца G суммируются, показывая общую биомассу фитопланктона в пробе в миллиграммах на литр (G50=CyMM(G12:G48)).

Формат ячеек столбца Н задан в процентном выражении. В этом столбце приводятся доли чис­ленности отдельных видов от общей численности фитопланктона в пробе. Значения ячеек столбца Н описываются формулой:

=E(номер строки)/СУММ(Е12:Е48). Формула =СУММ(Е12:Е48) задана также для ячейки Е50, в которой представлена общая численность фитопланктона в пробе в тысячах клеток на милилитр. Значение итоговой ячейки столбца Н — Н50 — тоже определяется суммой ячеек столбца (Н50=СУММ(Н12:Н48)), позволяя определить, правильно ли были внесены вручную данные первичного учета фитопланктона. Если при внесении данных были допущены ошибки, то значение ячейки Н50 будет не равно 100%.

В столбце I сведены индексы сопробности, соответствующие встреченным в пробе воды видам. Их значения забираются из листа «Названия» благодаря формуле:=ИНДЕКС(Названия!$Е:$Е;ПОИСКПОЗ(А(номерстроки);Названия!$А:$А;0)).

В ячейках столбца J содержатся относительные частоты встреченных в пробе видов по шкале, предложенной Пантле и Букком. Частоты описываются самой сложной в нашей «программе» функцией: =ЕСЛИ(I(номер строки)=0;0; ЕСЛИ(H(номер строки)<=0;0; ЕСЛИ(H(номер строки)<=0,03;1; ЕСЛИ(H(номер строки)<=0,04;2; ЕСЛИ(H(номер строки)<=0,1;3; ЕСЛИ(H(номер строки)<=0,2;5; ЕСЛИ(H(номер строки)<=0,4;7;9))))))).

Эта функция присваивает баллы соответствующим диапазонам доли численности вида, выражен­ной в процентах от общей численности. Кроме того, она предусматривает возможность отсутствия оп­ределенного значения индекса сапробности вида, присваивая ему балл, равный нулю. В ячейке J50 значения относительных частот отдельных видов суммируются по формулеJ50=CУMM(J12:J48).

Значения ячеек столбца К определяются формулой: К(номер строки) =I(номер строки)*J(номер строки), ячейки столбца К содержат произведения отно­сительных частот видов на их индексы сапробности. В ячейке К50 значения произведений также сумми­руются по формуле К50=СУММ(К12:К48).

И, наконец, значение индекса сапробности S пробы выводится в ячейке К51 по формуле =K50/J50.

В электронной таблице хранится информация о всех исследованных пробах фитопланктона, ох­ватывающая уникальный номер пробы, данные о месте и точке отбора, дате отбора, окончания анали­за, выдачи протокола, общей численности и биомассе, численности и биомассе основных таксономи­ческих групп, данные о пяти доминирующих по численности видах, их долях, видовых индексах сапроб­ности, примечания по отбору и анализу проб чистой вооды.

В заключение хочется подчеркнуть, что мы не предлагаем использовать в работе именно этот вариант группировки и связей данных. Мы хотели продемонстрировать возможность электронных таб­лиц, и в частности Excel, облегчить и ускорить обработку результатов гидробиологического анализа. Несомненно, что каждый гидробиолог, знакомый с Excel, сможет успешно использовать возможности этой электронной таблицы в соответствии с собственными задачами.